>您现在的位置:文学月刊 > 西方诗歌

IE6不能用gzip压缩脚本,一个流毒甚广的谣言

2019-08-13 11:59作者:admin

	IE6不能用gzip压缩脚本,一个流毒甚广的谣言

很多人遇到IE6下面脚本不运行的问题,在网上搜索一番后,都会遭遇到这篇流毒甚广的文章文章作者说跑到微软那一查,给的答复让我吐血:DonotenableHTTPcompressionforthescriptfiles请不要对脚本文件开启http压缩只好在服务器端增加对浏览器的识别代码,如果是ie6,就不压缩脚本文件了虽然脚本能运行了,可是用户体验就...哎,我恨ie6唉,说啥好呢?真相是,微软的答复()里面提供了两个解决方案,其中第一个描述的稍微啰嗦了一点,被这个作者直接忽略掉了。

第二个解决方案只有一句话,显然更容易被读懂:Toworkaroundthisproblem,youcandoeitherofthefollowing:IfyouuseaCache-Control:no-cacheHTTPheadertopreventthefilesfromcaching,,ifyousubstituteanExpiresHTTPheader,youdonottriggertheproblem.-虽然英文比较烂,四级老考不过,为了方便大家还是翻译一下吧,不然又该有人读不下去了。 要规避此问题,你可以在下面两个方案中选一种:1.如果你使用了Cache-Control:no-cache这个HTTP头来防止文件被缓存,移除这个头就好了。

有些情况下,如果你用一个Expires头来代替(前面这个出问题的http头),(也可以起到相同作用而)不会触发这个问题。

或者2.不要压缩脚本文件。

个人建议还是考虑第一方案。 本文作为前面一篇翻译文章《》的补充。

随机推荐

图文聚集

热门排行

最新文章